<!DOCTYPE html>
<html lang="en"  xmlns:og="http://ogp.me/ns#" xmlns:fb="https://www.facebook.com/2008/fbml"  >
<head>
<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
<meta http-equiv="X-UA-Compatible" content="text/html, charset=UTF-8, IE=edge, chrome=1">
			<link rel="canonical" href="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" />
											<link rel="alternate" media="only screen and (max-width: 640px)" href="https://www.cp24.com/mobile/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045"/>
						
<script type="text/javascript">
var videoPageUrl = "https://www.cp24.com/video";
</script>
<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/jquery-1.7.js"></script>
<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/jquery.cookie.js"></script>
<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/requireDependency.js"></script>
<script type="text/javascript">
  var kruxID = "InJgKD0f";
</script>
<!-- END Krux Controltag -->
	<meta name="viewport" content="width=1024" />
	<style>
		@font-face {font-family: 'Flama-Medium';src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/Flama-Medium.eot?s=2_614');src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/Flama-Medium.eot?#iefix&s=2_614') format('embedded-opentype'),url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/Flama-Medium.woff?s=2_614') format('woff'),url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/Flama-Medium.svg#font&s=2_614') format('svg');font-weight: normal;font-style:normal;}
	</style>
	<link rel="stylesheet" type="text/css" href="https://static.ctvnews.ca/bellmedia/common/css/common.css?v1" />

<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/jquery.polopoly.js"></script>


    <script type="text/javascript" src="https://z.moatads.com/bellmediaprebidheader755367530455/moatheader.js"></script>




		<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/js.cookie.min.js"></script>
	<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/jwt-decode.min.js"></script>
	<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/moment.min.js"></script>
	<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/jsrsasign-latest-all-min.js"></script>
	<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/ua-parser.min.js"></script>
	<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/userManagement.js"></script>
	
	
  	 <script  type="text/javascript">
		 function createUMLink(){
		    var umUrl = "https://account.bellmedia.ca/" + "?service=" + "cp24" + "&action=signin";
		    var currentPage = encodeURIComponent(window.location.href); 
		    
		    		        var fallBackVar = encodeURIComponent("https://www.cp24.com/umsignin");
		        umUrl = umUrl + "&fallback=" + fallBackVar ;
		       
		    		    
		    umUrl = umUrl + "&continue=" + currentPage ;
		    return umUrl;
		 }  
		 
		document.addEventListener('DOMContentLoaded', (event) => {
		      umSession.loginUrl = createUMLink();
              umSession.cookieDomain = '.cp24.com';
              umSession.accessCookieName =  'access';
              umSession.refreshCookieName = 'refresh';
              umSession.sessionCookieName = 'um_session';
              umSession.jwtSecurityKey = '-----BEGIN PUBLIC KEY-----' +'MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA4Lb/7NVtmj7x6i9nK5vJqwt3BlebdDQBoWSFlpMHaRyVhXp0uzSXC+GEoau8EaYGqnhe9oeVfQF8QXPO4RaVAKLkkLZtUKAXZvGhUTaSF8q4c3psiH7TPtgPCz/WQkidjLWCEnMrEfNBUZ/usMA97GN1LJWXmX6ZT09NbBEpEFS1fjzG5comGzJadBEzPXrjWrEMht1M5zr6PBDMcT/62JSi/aE2DQbqTcIe7HZQ9N5IiHn9h+uh2Ixn7i4MrQA0GMDzRoHZvDZZxltsZxH2Y/ECFRKe4oKm7muCBFcqw/oIeSnIE4jTSN5cutJUTPyXn+v+cyc/s8WuaxezUhPlmQIDAQAB' + '-----END PUBLIC KEY-----';
              umSession.enableJwtSecurity = true;
              umSession.refreshTokensUrl = 'https://account.bellmedia.ca/api/login/v2.1';
              umSession.token = btoa('cp24-web' + ':' + 'default');
              umSession.accessTokenRefreshTime =  0;
       	 
       	  	 if(umSession.isAuthenticatedWithoutTrigger()){
	            umSession.validateRefreshToken();
	         }
	         
	         var sessionCookie = Cookies.get( umSession.sessionCookieName, {domain:  umSession.cookieDomain});
	         var accessCookie = Cookies.get(this.accessCookieName, {domain: this.cookieDomain});
             var refreshCookie = Cookies.get(this.refreshCookieName, {domain: this.cookieDomain});
          
	         if(sessionCookie && (accessCookie || refreshCookie)){
	         	var cookieJson = JSON.parse(sessionCookie);
	         	umSession.throwError(cookieJson.statusCode);
	         }
	    });
  	</script>		                        <link rel="stylesheet" type="text/css" href="https://static.ctvnews.ca/bellmedia/common/css/jquery.lightbox-0.4.css" media="screen" />
                    <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/swfobject-2.2.js" ></script>
                    <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/lightbox/jquery.lightbox-0.4.min.js" ></script>
                    <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/jquery.validate-1.12.0.min.js" ></script>
                    <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/membership.js" ></script>
                      <link rel="stylesheet" type="text/css" href="https://static.ctvnews.ca/bellmedia/ctvnews/css/imageGallery.css" media="screen" />
                <!--[if IE 7]>
<style>
.content-secondary .videoPromoList .teaser .teaserTitle {margin-top: 0}
.content-secondary .videoPromoList .teaser .teaserTitle, .content-secondary .videoPromoList .teaser .teaserTitle a {line-height: 1}
.onlineExtras .right {float: left; margin-left: 0; width: auto}
.onlineExtras .button {padding-right: 0.9em}
.onlineExtras .arrow {position: absolute; margin-top: 5px; }
.topAd .boxAd p {position: static!important}
.fbpluginrecommendationsbarright {display: none!important}

.element.time {display: none!important}
</style>
 <![endif]-->

<!--[IF IE]>
<style>
.toronto2014 svg {overflow: hidden}
}
</style>
 <![endif]-->

                  <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/detectMobile.js" ></script>
                <script type="text/javascript">
if(!(window.console && console.log)) {
  console = {
    log: function(){},
    debug: function(){},
    info: function(){},
    warn: function(){},
    error: function(){}
  };
}  
function outputLog(source, str) {
  try {
        if (isDebug) {
            if (console && console.log) {
                console.log("[ " + source + " ]=" + str);
            }
        }
  } catch (e) {
  }
}
</script>  
                    <link rel="stylesheet" type="text/css" href="https://www.ctvnews.ca/cmlink/site-style-improvements-7.695789?v3" media="screen" />
                        <link rel="stylesheet" type="text/css" href="https://static.ctvnews.ca/bellmedia/cp24/css/cp24_layout.css" media="screen" />
                      <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="https://static.ctvnews.ca/bellmedia/cp24/css/ie_cp24.css" media="screen" />
      <![endif]-->
                      <!--[if IE 8]>
      <link rel="stylesheet" type="text/css" href="https://static.ctvnews.ca/bellmedia/common/css/ie8_common.css" media="screen" />
      <![endif]-->
                  <link rel="icon" type="image/ico" href="https://static.ctvnews.ca/bellmedia/cp24/img/favicon.ico" /> 
              <!--[if IE 7]>
<style>
.banner .search {margin-right: 65px!important;}
.banner .search FORM {width: 166px}
.time.element {margin-left: 185px!important}
.banner .search.element input[type="text"] {width: 125px!important}
</style>
<![endif]-->

              <link rel="apple-touch-icon" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon.png">
<link rel="apple-touch-icon" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-57x57.png" sizes="57x57">
<link rel="apple-touch-icon" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-60x60.png" sizes="60x60">
<link rel="apple-touch-icon" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-72x72.png" sizes="72x72">
<link rel="apple-touch-icon" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-76x76.png" sizes="76x76">
<link rel="apple-touch-icon" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-114x114.png" sizes="114x114">
<link rel="apple-touch-icon" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-120x120.png" sizes="120x120">
<link rel="apple-touch-icon" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-144x144.png" sizes="144x144">
<link rel="apple-touch-icon" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-152x152.png" sizes="152x152">
<link rel="apple-touch-icon-precomposed" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-precomposed.png">
<link rel="apple-touch-icon-precomposed" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-57x57-precomposed.png" sizes="57x57">
<link rel="apple-touch-icon-precomposed" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-60x60-precomposed.png" sizes="60x60">
<link rel="apple-touch-icon-precomposed" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-72x72-precomposed.png" sizes="72x72">
<link rel="apple-touch-icon-precomposed" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-76x76-precomposed.png" sizes="76x76">
<link rel="apple-touch-icon-precomposed" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-114x114-precomposed.png" sizes="114x114">
<link rel="apple-touch-icon-precomposed" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-120x120-precomposed.png" sizes="120x120">
<link rel="apple-touch-icon-precomposed" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-144x144-precomposed.png" sizes="144x144">
<link rel="apple-touch-icon-precomposed" href="https://www.ctvnews.ca/content/dam/cp24/newicons/favicon/apple-touch-icon-152x152-precomposed.png" sizes="152x152">

              <meta name="google-site-verification" content="AU6kMFW-Dd-lYTXYKS0K98fbD05aEV5AwDq7fCg3Tkk" />
<meta name="google-site-verification" content="Eh8MYsGLRxZ8BOo08VCgbZT0z1EZqs4oeMJiqrBggFc" />
<meta name="google-site-verification" content="hcrqeJADr3SMBZA5OxYeo_WA2U7PfQYko9FrM6PhwUA" />
<meta name="msvalidate.01" content="B1BCFEC1B3CD761CBEBC4CEBD2B351E5" />              <link rel="publisher" href="https://plus.google.com/u/0/b/104271651368601473061/"/>              <meta property="twitter:account_id" content="19636948" />                  <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/jquery.pinable.js" ></script>
                  <meta name="msapplication-starturl" content="https://www.cp24.com/?cid=ie9_taskbar_cp24" />
  <meta name="msapplication-tooltip" content="CP24 – Toronto and GTA News, Breaking News, Headlines, World, Entertainment, Sports, Lifestyle and m" />
  <meta name="msapplication-navbutton-color" content="#0183fd" />
              <meta name="msapplication-task" content="name=World;action-uri=https://www.cp24.com/world/cp24-world-more-7.289615/cp24-world-1.813059;icon-uri=http://static.ctvnews.ca/bellmedia/cp24/img/favicon.ico" />
            <meta name="msapplication-task" content="name=Local News;action-uri=https://www.cp24.com/news/cp24-top-stories-more-7.289613/cp24-top-stories-1.813056;icon-uri=http://static.ctvnews.ca/bellmedia/cp24/img/favicon.ico" />
            <meta name="msapplication-task" content="name=CP24 Videos;action-uri=https://www.cp24.com/video;icon-uri=http://static.ctvnews.ca/bellmedia/cp24/img/favicon.ico" />
                        
        <script type="text/javascript">
            (function() {
                /** CHARTBEAT HEADER CONFIGURATION START **/
                var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
                _sf_async_config.uid = 65778; //65778
                _sf_async_config.domain = 'cp24.com'; //'ctvnews.ca';
                _sf_async_config.flickerControl = false;
                _sf_async_config.useCanonical = true;
                _sf_async_config.useCanonicalDomain = true;
                /** CHARTBEAT HEADER CONFIGURATION END **/
            })();
        </script>
        <script async="true" src="//static.chartbeat.com/js/chartbeat_mab.js"></script>

        	<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/mdetect.js"></script>
 		  <link rel="stylesheet" type="text/css" href="/cmlink/ctv-styles-7.132" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/weather-link-7.729539" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/responsive-override-7.726278" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/hide-g-7.725977" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/ontario2014-7.523345" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/video-bin-column-css-7.489853" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/banner-temp-7.298239" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/player-style-7.363763" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/background-override-7.682833" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/sponsored-articles-7.688114" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/newmynews-7.701063" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/tsn-widget-7.701032" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/articlerightrail-7.699035" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/crush-banner-bandaid-7.687060" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/rightrail-poll-defaultbg-css-7.624335" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/cp24-styles-7.298238" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/pmh5050css-7.494541" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/story-related-7.343939" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/homepage-tabs-css-7.611240" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/brightcove-css-7.666274" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/election-article-rr-7.736915" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/articlestoryfarm-7.697834" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/bgk-edo-7.325901" />
		  <link rel="stylesheet" type="text/css" href="/cmlink/local-news-css-7.328470" />
		<link href="https://static.ctvnews.ca/bellmedia/common/css/responsive_layout.css" rel="stylesheet" type="text/css" media="screen, handheld, print, projection" />
	<link href="https://static.ctvnews.ca/bellmedia/common/css/print.css" rel="stylesheet" type="text/css" media="print" />
<!--[if IE]>
  <script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<!--[if lt IE 9]>
        <script>
        document.createElement('header');
        document.createElement('nav');
        document.createElement('section');
        document.createElement('article');
        document.createElement('aside');
        document.createElement('footer');
        document.createElement('hgroup');
        </script>
        <![endif]-->
<script type="text/javascript">
if(!(window.console && console.log)) {
  console = {
    log: function(){},
    debug: function(){},
    info: function(){},
    warn: function(){},
    error: function(){}
  };
}
</script>
	
    


	<!-- set index exchange script-->
				<script async src=//js-sec.indexww.com/ht/p/183816-221446884420070.js ></script>

<script>
window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
(function(){
	function retrieve(n){
		var m, k='kx'+n;
		if (window.localStorage) {
			return window.localStorage[k] || "";
		} else if (navigator.cookieEnabled) {
			m = document.cookie.match(k+'=([^;]*)');
			return (m && unescape(m[1])) || "";
		} else {
			return '';
		}
	}
	Krux.user = retrieve('user');
	Krux.segments = retrieve('segs') && retrieve('segs').split(',') || [];
})();
</script>

<!-- Permutive start -->
  <script src="https://static.ctvnews.ca/bellmedia/common/js/sha256.js"></script>
  <script>
    const permutiveID = localStorage.getItem('permutive-id');
    if (permutiveID) {
      window.hashedPermutiveID = sha256.hex(permutiveID);
      document.writeln('<img height="1" width="1" style="display:none" src="https://pixel.tapad.com/idsync/ex/receive?partner_id=3279&partner_device_id=' + hashedPermutiveID + '"/>');
    }
  </script>

  <script id="permutiveScript" type="text/javascript" >
    !function (n, e, o, r, i) {
      if (!e) {
        e = e || {}, window.permutive = e, e.q = [], e.config = i || {}, e.config.projectId = o, e.config.apiKey = r, e.config.environment = e.config.environment || "production";
        for (var t = ["addon", "identify", "track", "trigger", "query", "segment", "segments", "ready", "on", "once", "user", "consent"], c = 0; c < t.length; c++) {
          var f = t[c];
          e[f] = function (n) {
            return function () {
              var o = Array.prototype.slice.call(arguments, 0);
              e.q.push({functionName: n, arguments: o})
            }
          }(f)
        }
      }
    }(document, window.permutive, "289d106c-df24-4cd9-a9fa-753e928c23ad", "b1a4360a-3db9-4b39-b09d-c3e14666840a", {});
    const idCheck = () => {
      const getCookie = (cname) => {
        const name = cname + "=";
        const decodedCookie = decodeURIComponent(document.cookie);
        const ca = decodedCookie.split(';');
        for (var i = 0; i < ca.length; i++) {
          var c = ca[i];
          while (c.charAt(0) == ' ') {
            c = c.substring(1);
          }
          if (c.indexOf(name) == 0) {
            return c.substring(name.length, c.length);
          }
        }
        return false;
      };

      const setCookie = (cname, cvalue, exdays) => {
        let date = new Date();
        date.setTime(date.getTime() + (exdays * 24 * 60 * 60 * 1000));
        const expires = "expires=" + date.toUTCString();
        document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
      };

      const storedCookie = getCookie("permutiveID");

      if (storedCookie) {
        permutive.identify(storedCookie);
      }

      setCookie("permutiveID", permutive.context.user_id, 365);
    };

    permutive.readyWithTimeout=function(e,i,t){var u=!1,n=function(){u||(e(),u=!0)};(t=t||1/0)!==1/0&&window.setTimeout(n,t),permutive.ready(n,i)};
    
   <!-- Identity Management -->
	document.addEventListener("DOMContentLoaded",function() {
	    if (typeof digitalData != "undefined" && typeof digitalData.user.userId != "undefined") {
	      permutive.identify([{
	        "id": digitalData.user.userId,
	        "tag": "bell_id"
	      }]);
	    }
	 }); 

    permutive.ready(idCheck);
    permutive.addon('web', {});
  </script>
  <script id="permutive" async="" type="text/javascript" src="https://cdn.permutive.com/289d106c-df24-4cd9-a9fa-753e928c23ad-web.js"></script>
<!-- Permutive end -->


<script type='text/javascript'>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</script>

<script type="text/javascript">
  window.googletag = window.googletag || {}, window.googletag.cmd = window.googletag.cmd || [], window.googletag.cmd.push(function() {
    if (0 === window.googletag.pubads().getTargeting("permutive").length) {
      window.headertag = window.headertag || {};
      window.headertag.cmd = window.headertag.cmd || [];
      window.headertag.cmd.push(function() {
        try {
          var segs = JSON.parse(localStorage._pdfps || '[]').slice(0, 250);
          window.headertag.setUserKeyValueData({
            segments: {
              "permutive": segs
            }
          });
        } catch (e) {}
      });
      var g = localStorage.getItem('_pdfps');
      window.googletag.pubads().setTargeting("permutive", g ? JSON.parse(g) : [])
      // console.log('ad targeting permutive kvs: ', g);
    } else {
      try {
        var segs = JSON.parse(localStorage._pdfps || '[]').slice(0, 250);
        window.headertag.setUserKeyValueData({
          segments: {
            "permutive": segs
          }
        });
      } catch (e) {}
    }
  });
</script>

<script>
    var cbAuthor;
</script>
  <title>'Enough is enough': Thousands demand new gun safety laws | CP24.com </title>
      <meta name="description" content="Thousands of people rallied on the National Mall and across the United States on Saturday in a renewed push for gun control measures after recent deadly mass shootings from Uvalde, Texas, to Buffalo, New York, that activists say should compel Congress to act." />
        <meta name="keywords" content="toronto, breaking news, doug ford, crime, live video, covid 19 ontario, toronto real estate, traffic times" />
        <meta name="news_keywords" content="US protests, US gun laws, March for Our Lives" />
  <link rel="amphtml" href="https://beta.cp24.com/world/2022/6/11/1_5943045.html">
<meta name="robots" content="noarchive,noodp" />
<meta name="robots" content="index,follow,noodp" />
<meta name="robots" content="ACAP allow-index" />
    	      		<meta property="fb:pages" content="265325440237679" />
      	      		<meta property="fb:pages" content="525693370806473" />
      	<meta name="dc.date.modified" content="2022-06-11">              
                      <meta itemprop="name" content="'Enough is enough': Thousands demand new gun safety laws" />
                        <meta itemprop="description" content="Thousands of people rallied on the National Mall and across the United States on Saturday in a renewed push for gun control measures after recent deadly mass shootings from Uvalde, Texas, to Buffalo, New York, that activists say should compel Congress to act." />
                                  <meta itemprop="url" content="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" />
                    <meta itemprop="image" content="https://www.cp24.com/polopoly_fs/1.5943188.1654983876!/httpImage/image.jpg_gen/derivatives/landscape_300/image.jpg" />
                    <meta property="og:type" content="article" />
          <meta property="og:title" content="'Enough is enough': Thousands demand new gun safety laws" />
          <meta property="og:url" content="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" />
          <meta property="og:description" content="Thousands of people rallied on the National Mall and across the United States on Saturday in a renewed push for gun control measures after recent deadly mass shootings from Uvalde, Texas, to Buffalo, New York, that activists say should compel Congress to act." />
    
          <meta property="og:image" content="https://www.cp24.com/polopoly_fs/1.5943188.1654983876!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg" />
	  <meta itemprop="thumbnailUrl" content="https://www.cp24.com/polopoly_fs/1.5943188.1654983876!/httpImage/image.jpg_gen/derivatives/landscape_1020/image.jpg" /> <!-- schema.org -->
        <meta property="og:site_name" content="CP24" />
                    <meta name="twitter:title" content="'Enough is enough': Thousands demand new gun safety laws" />
          <meta name="twitter:card" content="summary_large_image" />
          <meta name="twitter:url" content="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" />
          <meta name="twitter:description" content="Thousands of people rallied on the National Mall and across the United States on Saturday in a renewed push for gun control measures after recent deadly mass shootings from Uvalde, Texas, to Buffalo, New York, that activists say should compel Congress to act." />
              <meta name="twitter:site" content="@cp24" />
      <meta name="twitter:creator" content="@cp24" />
              <meta name="twitter:image:src" content="https://www.cp24.com/polopoly_fs/1.5943188.1654983876!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg" />
                  <meta name="author" content="Ashraf Khalil And Darlene Superville" />
      <meta property="article:author" content="Ashraf Khalil And Darlene Superville" />
    <meta itemprop="headline" content="'Enough is enough': Thousands demand new gun safety laws"/>
  <meta property="og:locale" content="en_CA" />
      <meta property="article:published_time" content="2022-06-11T14:45:00-04:00"> 
  <meta itemprop="datePublished" content="2022-06-11T14:45:00-04:00">
        <meta property="article:modified_time" content="2022-06-11T17:45:08-04:00">
  <meta itemprop="dateModified" content="2022-06-11T17:45:08-04:00">
          <meta property="article:section" content="World">  
    
      

      <script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "NewsArticle",
      "headline": "'Enough is enough': Thousands demand new gun safety laws",
      "description" : "Thousands of people rallied on the National Mall and across the United States on Saturday in a renewed push for gun control measures after recent deadly mass shootings from Uvalde, Texas, to Buffalo, New York, that activists say should compel Congress to act.",
                  
            	
                                    "author" :[{
                          "@type":"Person",
              "name" : "Ashraf Khalil And Darlene Superville",
              "sameAs": "The Associated Press"
            }
                    ],
                    "publisher":{
        "@type": "NewsMediaOrganization",
               "name": "CP24",
                "logo": {
            "@type": "ImageObject",
            "url": "https://www.cp24.com/polopoly_fs/7.724915!/httpImage/image.png",            
            "width": 124,
            "height": 60
        }
      },
              "contactPoint" : [
          {
            "@type" : "ContactPoint",
            "contactType" : "Newsroom Contact",
            "email" : "",
            "url" : ""
          }
        ],
            "image": {
        "@type": "ImageObject",
        "url": "https://www.cp24.com/polopoly_fs/1.5943188.1654983876!/httpImage/image.jpg_gen/derivatives/landscape_1020/image.jpg",
        "height": 1020,
        "width": 574
      },
      "mainEntityOfPage":"https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045",
        		  		"dateModified": "2022-06-11T17:45:08-04:00",
  		  	  	  		  			"datePublished": "2022-06-11T14:45:00-04:00"
  		  	    }
</script>
    
  
<script type="text/javascript">
  jQuery.ajaxSetup({
    cache: 'true'
  });
</script>
  <link rel="alternate" type="application/rss+xml" title="CP24 Top Stories Full Text RSS feed" href="https://www.cp24.com/rss/cp24-top-stories-full-text-rss-feed-1.5859135" />  <link rel="alternate" type="application/rss+xml" title="CP24 Tonight Full Show" href="https://www.cp24.com/rss/cp24-tonight-full-show-1.5421380" />  <link rel="alternate" type="application/rss+xml" title="Top Stories" href="https://www.cp24.com/rss/top-stories-1.1129631" />


<script type="text/javascript" src="//assets.adobedtm.com/launch-EN8508e1965b004de29de2dbd977d7156a.min.js"></script> 
</head>

<body id="top">
  <div id="insertForm"></div>
<script type="text/javascript">
detectMobile();
</script>
<script type="text/javascript"><!--jQuery(document).ready(function() {window.pageLoaded=true});//--></script>


	  <div class="topAd">
        



  
  
    <script type="application/ld+json">
{
  "@context" : "http://schema.org",
  "@type" : "Organization",
  "name" : "CP24",
  "url" : "https://www.cp24.com",
  "logo" : "https://www.cp24.com/polopoly_fs/7.666181!/httpImage/image.jpg",
  "sameAs" : [
    "https://www.facebook.com/CP24Toronto",
    "https://www.twitter.com/CP24",
    "https://www.instagram.com/cp24breakingnews",
    "https://plus.google.com/+Cp24TorontoBreakingNews"
  ] 
}
</script>
  
  
  
    

<div class='cp24-nav-block'>
  
  



  
  
    <div class="links-search">
	<div class="element list none">
		<ul class="linklist horizontal">                               
							<li><a href="https://www.facebook.com/CP24Toronto" target="_blank"><span class="facebook"></span></a></li>
							<li><a href="https://twitter.com/CP24" target="_blank"><span class="twitter"></span></a></li>
							<li><a href="https://www.instagram.com/cp24breakingnews/" target="_blank"><span class="instagram"></span></a></li>
					</ul>
		<div class="clearfix"></div>
	</div>
			
    

<div class="search element" id="search_7.127">
      <a href="" class="sb">Search</a>
  <form action="https://www.cp24.com/search-results/search-cp24-7.127" method="get" class="frm frmSearch">
    <input class="bt submit" type="submit" value="" />
    <div class="form">
      <label class="hidden" for="search_bar_7_127">Search CP24</label>
      <input id="search_bar_7_127" placeholder="Search CP24" type="text" name="q" value="" />
      <a class="close">X</a>
    </div>
  </form></div>	</div>
  
  
  
    <a class="logo logo_cp24" href="https://www.cp24.com/" title="CP24.com"></a>
  
  
  
    

<div class='watch-live-header'>
  
  



  
  
    <div>
            	              
    
        <a   href="https://www.cp24.com/video?clipId=68595"   >WATCH LIVE</a>

        </div>

  

  </div>
  
  
  
                                                            
<div class="mainnavigation_wrapper ">
<div class="mainnavigation_subnavigation_wrapper">
<nav class="mainnavigation container" >
        <ul class="menu menuSite menuTwo section-links">
            
                      
                                    
                        						            
            <li class="mainnavigation_item item_7289808 bm-red ">
            <span class="mainnavigation_item_text">
                            <span class="navlink">
                                  NEWS
                                </span>
            
                          <span class="arrow"></span>
                        </span>
            </li>
                
                      
                                    
                        						            
            <li class="mainnavigation_item item_7289810 bm-blue ">
            <span class="mainnavigation_item_text">
                          <span class="navlink">
                            	                
    
        <a   href="https://www.cp24.com/weather"  title="Weather" >WEATHER</a>

                      </span>
            
                        </span>
            </li>
                
                      
                                    
                        						            
            <li class="mainnavigation_item item_7291933 bm-yellow ">
            <span class="mainnavigation_item_text">
                            <span class="navlink">
                                  TRAFFIC
                                </span>
            
                          <span class="arrow"></span>
                        </span>
            </li>
                
                      
                                    
                        						            
            <li class="mainnavigation_item item_7291945 bm-green ">
            <span class="mainnavigation_item_text">
                            <span class="navlink">
                                  VIDEO
                                </span>
            
                          <span class="arrow"></span>
                        </span>
            </li>
                
                      
                                    
                        						            
            <li class="mainnavigation_item item_7291951 bm-redDark ">
            <span class="mainnavigation_item_text">
                            <span class="navlink">
                                  CP24 BREAKFAST
                                </span>
            
                          <span class="arrow"></span>
                        </span>
            </li>
                
                      
                                    
                        						            
            <li class="mainnavigation_item item_7580471 bm-twitter_cyan ">
            <span class="mainnavigation_item_text">
                            <span class="navlink">
                                  Lifestyle
                                </span>
            
                          <span class="arrow"></span>
                        </span>
            </li>
                
                      
                                    
                        						            
            <li class="mainnavigation_item item_7292047 bm-black ">
            <span class="mainnavigation_item_text">
                            <span class="navlink">
                                  MORE
                                </span>
            
                          <span class="arrow"></span>
                        </span>
            </li>
                    </ul>
</nav>
                             <div class="drop_down link_id_7289808" style="display:none;">
                    <div class="drop_down_element_container bm-red">
      <a href="#" class="close" title="Close menu"><span></span></a>
                



  <div class="element list none   ">
                  <ul class="linklist horizontal">
                                  
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/"  title="Back to homepage" >Home</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	              
    
        <a   href="https://www.cp24.com/news"   >Local</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/world"  title="World" >World</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	              
    
        <a   href="https://www.cp24.com/entertainment-news"   >Entertainment</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/sports"  title="Sports" >Sports</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/news/the-mayor"  title="The Mayor" >The Mayor</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/photo-galleries"  title="Photo Galleries" >Photo Galleries</a>

                                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>
          </div>
            <script type="text/javascript">
          jQuery(document).ready(function() {
            jQuery(".item_7289808").click(click_7289808);
            jQuery(".link_id_7289808 .close").click(click_7289808);
          });
          </script>
        </div>
            <script type="text/javascript">
          function click_7289808() {
            var itemSelector = ".item_7289808";
            var selector = ".link_id_7289808";
            var shouldOpen = ((jQuery(selector + ":visible").size() <= 0) && (jQuery(selector + " div").size() > 0));
            if (jQuery(".drop_down:visible").size() > 0) {
              jQuery(".drop_down:visible").hide();
              jQuery(".mainnavigation_item").removeClass("active");
            }
            if(shouldOpen) {
              jQuery(selector).slideDown();
              jQuery(itemSelector).toggleClass("active");
            }
          }
      </script>
                                       <div class="drop_down link_id_7289810" style="display:none;">
                          <script type="text/javascript">
          jQuery(document).ready(function() {
            jQuery(".item_7289810").click(click_7289810);
            jQuery(".link_id_7289810 .close").click(click_7289810);
          });
          </script>
        </div>
            <script type="text/javascript">
          function click_7289810() {
            var itemSelector = ".item_7289810";
            var selector = ".link_id_7289810";
            var shouldOpen = ((jQuery(selector + ":visible").size() <= 0) && (jQuery(selector + " div").size() > 0));
            if (jQuery(".drop_down:visible").size() > 0) {
              jQuery(".drop_down:visible").hide();
              jQuery(".mainnavigation_item").removeClass("active");
            }
            if(shouldOpen) {
              jQuery(selector).slideDown();
              jQuery(itemSelector).toggleClass("active");
            }
          }
      </script>
                                       <div class="drop_down link_id_7291933" style="display:none;">
                    <div class="drop_down_element_container bm-yellow">
      <a href="#" class="close" title="Close menu"><span></span></a>
                



  <div class="element list none   ">
                  <ul class="linklist horizontal">
                                  
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/commuter-centre"  title="Commuter Centre" >Commuter Centre</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	              
    
        <a   href="http://www.cp24.com/commuter-centre#traffic"   >Traffic</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	              
    
        <a   href="http://www.cp24.com/commuter-centre#transit"   >Transit</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/lifestyle/travel/air-travel"  title="Air Travel" >Air Travel</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	              
    
        <a   href="http://www.cp24.com/commuter-centre#border-crossing"   >Border Crossings</a>

                                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>
          </div>
            <script type="text/javascript">
          jQuery(document).ready(function() {
            jQuery(".item_7291933").click(click_7291933);
            jQuery(".link_id_7291933 .close").click(click_7291933);
          });
          </script>
        </div>
            <script type="text/javascript">
          function click_7291933() {
            var itemSelector = ".item_7291933";
            var selector = ".link_id_7291933";
            var shouldOpen = ((jQuery(selector + ":visible").size() <= 0) && (jQuery(selector + " div").size() > 0));
            if (jQuery(".drop_down:visible").size() > 0) {
              jQuery(".drop_down:visible").hide();
              jQuery(".mainnavigation_item").removeClass("active");
            }
            if(shouldOpen) {
              jQuery(selector).slideDown();
              jQuery(itemSelector).toggleClass("active");
            }
          }
      </script>
                                       <div class="drop_down link_id_7291945" style="display:none;">
                    <div class="drop_down_element_container bm-green">
      <a href="#" class="close" title="Close menu"><span></span></a>
                



  <div class="element list none   ">
                  <ul class="linklist horizontal">
                                  
            
            
    <li>
              
                                    
           
                        	              
    
        <a   href="https://www.cp24.com/live"   >CP24 LIVE</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	              
      
        <a class="unmutePlayer"  href="https://www.cp24.com/video?binId=1.1127680"   >All Video</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/news/the-mayor"  title="The Mayor" >The Mayor</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	              
    
        <a   href="https://www.cp24.com/askalawyer"   >Ask A Lawyer</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/talk-shows/hot-property"  title="Hot Property" >Hot Property</a>

                                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>
          </div>
            <script type="text/javascript">
          jQuery(document).ready(function() {
            jQuery(".item_7291945").click(click_7291945);
            jQuery(".link_id_7291945 .close").click(click_7291945);
          });
          </script>
        </div>
            <script type="text/javascript">
          function click_7291945() {
            var itemSelector = ".item_7291945";
            var selector = ".link_id_7291945";
            var shouldOpen = ((jQuery(selector + ":visible").size() <= 0) && (jQuery(selector + " div").size() > 0));
            if (jQuery(".drop_down:visible").size() > 0) {
              jQuery(".drop_down:visible").hide();
              jQuery(".mainnavigation_item").removeClass("active");
            }
            if(shouldOpen) {
              jQuery(selector).slideDown();
              jQuery(itemSelector).toggleClass("active");
            }
          }
      </script>
                                       <div class="drop_down link_id_7291951" style="display:none;">
                    <div class="drop_down_element_container bm-redDark">
      <a href="#" class="close" title="Close menu"><span></span></a>
                



  <div class="element list none   ">
                  <ul class="linklist horizontal">
                                  
            
            
    <li>
              
                                    
           
                        	              
    
        <a   href="https://www.cp24.com/cp24-breakfast/"   >Home</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	              
      
        <a class="unmutePlayer"  href="https://www.cp24.com/video?binId=7.395214"   >All Videos</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/cp24-breakfast/milestones"  title="Milestones" >Milestones</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/cp24-breakfast/green-room"  title="Green Room" >Green Room</a>

                                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>
          </div>
            <script type="text/javascript">
          jQuery(document).ready(function() {
            jQuery(".item_7291951").click(click_7291951);
            jQuery(".link_id_7291951 .close").click(click_7291951);
          });
          </script>
        </div>
            <script type="text/javascript">
          function click_7291951() {
            var itemSelector = ".item_7291951";
            var selector = ".link_id_7291951";
            var shouldOpen = ((jQuery(selector + ":visible").size() <= 0) && (jQuery(selector + " div").size() > 0));
            if (jQuery(".drop_down:visible").size() > 0) {
              jQuery(".drop_down:visible").hide();
              jQuery(".mainnavigation_item").removeClass("active");
            }
            if(shouldOpen) {
              jQuery(selector).slideDown();
              jQuery(itemSelector).toggleClass("active");
            }
          }
      </script>
                                       <div class="drop_down link_id_7580471" style="display:none;">
                    <div class="drop_down_element_container bm-twitter_cyan">
      <a href="#" class="close" title="Close menu"><span></span></a>
                



  <div class="element list none   ">
                  <ul class="linklist horizontal">
                                  
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/lifestyle"  title="Lifestyle Home" >Home</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/lifestyle/human-interest"  title="Human Interest" >Human Interest</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/lifestyle/health"  title="Health" >Health</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/lifestyle/technology"  title="Technology" >Technology</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/lifestyle/real-estate"  title="Real Estate" >Real Estate</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/lifestyle/travel"  title="Travel" >Travel</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/news/top-social-stories"  title="Top Social Stories" >Top Social Stories</a>

                                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>
          </div>
            <script type="text/javascript">
          jQuery(document).ready(function() {
            jQuery(".item_7580471").click(click_7580471);
            jQuery(".link_id_7580471 .close").click(click_7580471);
          });
          </script>
        </div>
            <script type="text/javascript">
          function click_7580471() {
            var itemSelector = ".item_7580471";
            var selector = ".link_id_7580471";
            var shouldOpen = ((jQuery(selector + ":visible").size() <= 0) && (jQuery(selector + " div").size() > 0));
            if (jQuery(".drop_down:visible").size() > 0) {
              jQuery(".drop_down:visible").hide();
              jQuery(".mainnavigation_item").removeClass("active");
            }
            if(shouldOpen) {
              jQuery(selector).slideDown();
              jQuery(itemSelector).toggleClass("active");
            }
          }
      </script>
                                       <div class="drop_down link_id_7292047" style="display:none;">
                    <div class="drop_down_element_container bm-black">
      <a href="#" class="close" title="Close menu"><span></span></a>
                



  <div class="element list none   ">
                  <ul class="linklist horizontal">
                                  
            
            
    <li>
              
                                    
           
                        	              
    
        <a   href="https://www.cp24.com/app"   >CP24 APP</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	              
    
        <a   href="https://www.cp24.com/faq"   >Video Help</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/more/contact-us"  title="Contact Us" >Contact Us</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	              
    
        <a   href="https://www.cp24.com/cp24-supports"   >CP24 Supports</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/breaking-news-email"  title="Breaking News Email" >Breaking News Email</a>

                                                        </li>
        
            
            
    <li>
              
                                    
           
                                                            </li>
        
            
            
    <li>
              
                                    
           
                        	                
    
        <a   href="https://www.cp24.com/talk-shows"  title="Talk Shows" >Talk Shows</a>

                                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>
          </div>
            <script type="text/javascript">
          jQuery(document).ready(function() {
            jQuery(".item_7292047").click(click_7292047);
            jQuery(".link_id_7292047 .close").click(click_7292047);
          });
          </script>
        </div>
            <script type="text/javascript">
          function click_7292047() {
            var itemSelector = ".item_7292047";
            var selector = ".link_id_7292047";
            var shouldOpen = ((jQuery(selector + ":visible").size() <= 0) && (jQuery(selector + " div").size() > 0));
            if (jQuery(".drop_down:visible").size() > 0) {
              jQuery(".drop_down:visible").hide();
              jQuery(".mainnavigation_item").removeClass("active");
            }
            if(shouldOpen) {
              jQuery(selector).slideDown();
              jQuery(itemSelector).toggleClass("active");
            }
          }
      </script>
           </div>
</div>
  

  </div>
  
  
  
    <style type="text/css">
  .topstorybn .teaser-image-top .bn-headline .tag {
   background: #a80a01;
   color: #fff;
   font-weight: bold;
   padding: 4px;
   display: inline-block;
}
  </style>
  
  </div>
	
<!-- BEGIN BANNERS -->
<header class="banner clearfix">
  <div class="skip-links hidden">
    <ul>
      <li><a href="#responsive_main" title="skip to content">Skip to Main Content</a></li>
          </ul>
  </div><!-- END .skip-links -->
  
        <div class="content-wrapper">
        



  
  
      

  
  
  
      

  
  
  
      

  
  
  
    

<div class='unmutePlayer'>
  
  



  
  
      

  
  
  
      

  
  
  
      

  
  
  
      

  

  </div>
  
  
  
    
                                    <div class="boxAd secondClass ">
							                            <div class="advert">
        
                        
                                                                                              
               
	        	          								<div id="div-gpt-ad-728_90-1">
				<script type="text/javascript">
				    if (document.querySelector('.advert') !== null) {
				        googletag.cmd.push(function () {
				            headertag.display("div-gpt-ad-728_90-1");
				        });
				    }
				</script>
				</div>
	          	                
                    								<p class="ad-below">Advertisement</p>
							            </div>
                
                    </div>
        
    
  
  
  </div>
  </header><!-- END .banner -->
<!-- END BANNERS -->




<div class="content">
  
  <div class="content-wrapper">
              
    

                
                                                                  <div class="content-primary" id="responsive_main">
                

                                 
    
        <script type="text/javascript">

    /*Create global object which loads
                * twitter script asynchronously
                */
                window.twttr = (function (d, s, id) {
                    var t, js, fjs = d.getElementsByTagName(s)[0];
                    if (d.getElementById(id)) return; js = d.createElement(s); js.id = id;
                    js.src = "https://platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs);
                    return window.twttr || (t = { _e: [], ready: function (f) { t._e.push(f) } });
                }(document, "script", "twitter-wjs"));
                    /*Twitter click tracking funciton*/
                function transferTwitterClickToOmniture(intentEvent) {
                    if (!intentEvent) return;
                    var label = intentEvent.region;
                    Tracking.trackSocial(label + "btn_click");
                }
    
                /* Create twitter share button and bind to built-in ready
                 * method which contains click tracking method execution
                 */
                twttr.ready(function (twttr) {
                    twttr.widgets.createShareButton(
                        'https://twitter.com/share',
                        document.getElementById('twitter_share')
                    );
                                        twttr.events.bind('click', transferTwitterClickToOmniture);
                                    });
            </script>
                
          <section class="story project clearfix">
                <div class="container">
          <div class="element article">
                                                   <h1  class="articleHeadline">'Enough is enough': Thousands demand new gun safety laws</h1>
                        
                                                                                                            <div class="image top imgTop">
                        <img src='https://www.cp24.com/polopoly_fs/1.5943188.1654983876!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg' alt='March for Our Lives' width='620' title='March for Our Lives' height='349' />                            <p>People hold signs in the second March for Our Lives rally in support of gun control in front of the Washington Monument, Saturday, June 11, 2022, in Washington. The rally is a successor to the 2018 march organized by student protestors after the mass shooting at a high school in Parkland, Fla. (AP Photo/Jose Luis Magana)</p>
                      </div>
                                                                                <div class="tools clearfix">
                                  
  <h2>Share:</h2>
  <div id="fb-root"></div>
<script type="text/javascript">

jQuery(document).ready(
  function(){
    window.fbAsyncInit = function() {
      FB.init({
        appId      : '117341078420651', // App ID
        channelUrl : 'https://static.ctvnews.ca/bellmedia/common/channel.html', // Channel File
        status     : true, // check login status
        cookie     : true, // enable cookies to allow the server to access the session
        xfbml      : true  // parse XFBML
      });
            FB.Event.subscribe("edge.create", function (response) {
        Tracking.trackSocial('facebook_like_btn_click');
      });
      
      // BEGIN: Facebook clicks on unlike button
      FB.Event.subscribe("edge.remove", function (response) {
        Tracking.trackSocial('facebook_unlike_btn_click');
      });
          };
   
            var plusoneOmnitureTrack = function () {
      $(function () {
        Tracking.trackSocial('google_plus_one_btn');
      })
    }
        var facebookCallback = null;
        requiresDependency('https://connect.facebook.net/en_US/all.js#xfbml=1&appId=117341078420651', facebookCallback, 'facebook-jssdk');
  });
</script>
<div class="StoryShare">
    <a id="twitter_share" href="https://twitter.com/share" class="twitter-share-button b" data-via="cp24" data-text="'Enough is enough': Thousands demand new gun safety laws" data-url="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" data-count="none">&nbsp;</a>
    <a href="https://reddit.com/submit?url=https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045&title='Enough is enough': Thousands demand new gun safety laws" target="_blank" class="reddit-button">Reddit</a>
    <div id="fbctv"><div class="fb-share-button" data-href="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" data-layout="button_count" data-size="small"><a target="_blank" href="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045&amp;src=sdkpreparse" class="fb-xfbml-parse-ignore">Share</a></div></div>
</div>                                                                    <fb:recommendations-bar href="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" action="recommend" read_time="20" max_age="2" num_recommendations="2"></fb:recommendations-bar>
                      <div class='top-tool'>
                                    <h2>Text:</h2>
                                    <ul>
                                        <li class="narrow"><a href="#" class="increaseTextSize">&nbsp;</a></li>
                    <li class="narrow"><a href="#" class="decreaseTextSize">&nbsp;</a></li>

                                                                                                                              </ul>
                </div>
              </div>
                    <div class="clearfix">
          <div class="s-data">
          
                        <br>
                Ashraf Khalil And Darlene Superville, The Associated Press        </span>
    
                

                <br />

                <span class="date">
                  Published Saturday, June 11, 2022 2:45PM EDT
                </span>

                <br />

                                  <span class="date">
                    Last Updated Saturday, June 11, 2022 5:45PM EDT
                  </span>
                                              </div>
                                                              <div class="articleBody">
                 <p>
	WASHINGTON (AP) - Thousands of people rallied on the National Mall and across the United States on Saturday in a renewed push for gun control measures after recent deadly mass shootings from Uvalde, Texas, to Buffalo, New York, that activists say should compel Congress to act.</p>
<p>
	“Enough is enough,” District of Columbia Mayor Muriel Bowser told the second March for Our Lives rally in her city. “I speak as a mayor, a mom, and I speak for millions of Americans and America's mayors who are demanding that Congress do its job. And its job is to protect us, to protect our children from gun violence.”</p>
<p>
	Speaker after speaker in Washington called on senators, who are seen as a major impediment to legislation, to act or face being voted out of office, especially given the shock to the nation's conscience after 19 children and two teachers were killed May 24 at Robb Elementary School in Uvalde.</p>
<p>
	“If our government can't do anything to stop 19 kids from being killed and slaughtered in their own school, and decapitated, it's time to change who is in government,” said David Hogg, a survivor of the 2018 shooting that killed 17 students and staff at Marjory Stoneman Douglas High School in Parkland, Florida.</p>
<p>
	A co-founder of the March For Our Lives organization that was created after that shooting and held its first rally in Washington not long afterward, Hogg led the crowd in chants of “Vote them out.”</p>
<p>
	Another Parkland survivor and group co-founder, X Gonzalez, delivered an impassioned, profanity-laced plea to Congress for change. “We are being murdered,” they screamed and implored Congress to “act your age, not your shoe size.”</p>
<p>
	Added Yolanda King, granddaughter of Martin Luther King Jr.: “This time is different because this isn't about politics. It's about morality. Not right and left, but right and wrong, and that doesn't just mean thoughts and prayers. That means courage and action.”</p>
<p>
	Manuel Oliver, whose son, Joaquin, was killed in the Parkland shooting, called on students “to avoid going back to school until our elected leaders stop avoiding the crisis of gun violence in America and start acting to save our lives.”</p>
<p>
	Hundreds gathered at an amphitheater in Parkland, where Debra Hixon, whose husband, high school athletic director Chris Hixon, died in the shooting, said it is “all too easy” for young men to walk into stores and buy weapons.</p>
<p>
	“Going home to an empty bed and an empty seat at the table is a constant reminder that he is gone,” said Hixon, who now serves as a school board member. “We weren't done making memories, sharing dreams and living life together. Gun violence ripped that away from my family.”</p>
<p>
	In San Antonio, about 85 miles east of Uvalde, marchers chanted “Hey, hey, ho, ho, the NRA has got to go.” A man who said he helped to organize the rally, Frank Ruiz, called for gun reform laws similar to those enacted in Florida after the Parkland shooting that focused on raising the age for purchasing certain firearms and flagging those with mental health issues.</p>
<p>
	The U.S. House has passed bills to raise the age limit to buy semi-automatic weapons and establish federal “red flag” laws. A bipartisan group of senators had hoped to reach agreement this week on a framework for addressing the issue and held talks Friday, but no deal was announced.</p>
<p>
	President Joe Biden, who was in California when the Washington rally began, said his message to demonstrators was “keep marching” and added that he is “mildly optimistic” about legislative negotiations to address gun violence. Biden recently delivered an impassioned address to the nation in which he called for several steps, including raising the age limit for buying assault-style weapons.</p>
<p>
	In New York City, Mayor Eric Adams, who campaigned on reining in violence in the nation's largest city, joined state Attorney General Letitia James, who is suing the National Rifle Association, in leading activists across the Brooklyn Bridge.</p>
<p>
	“Nothing happens in this country until young people stand up - not politicians,” James said.</p>
<p>
	Joining the call for change were hundreds of people who rallied in a park outside the courthouse in Portland, Maine, before they marched through the Old Port and gathered outside of City Hall. At one point, they chanted, “Hey, hey, hey, NRA. How many kids did you kill today.”</p>
<p>
	John Wuesthoff, a retired lawyer in Portland, said he was waving an American flag during the rally as a reminder that gun control is “not un-American.”</p>
<p>
	“It's very American to have reasonable regulations to save the lives of our children,” he said.</p>
<p>
	Hundreds of protesters in Milwaukee marched from the county courthouse to the city's Deer District, where last month 21 people were injured in shootings on the night of an NBA playoff game. Organizer Tatiana Washington, whose aunt was killed by gun violence in 2017, said this year's march is particularly significant to Milwaukee residents.</p>
<p>
	“A lot of us are still very heavily thinking about the mass shooting that occurred after the Bucks game,” Washington said. “We shouldn't be scared to go watch our team in the playoffs and live in fear that we're going to be shot at.”</p>
<p>
	The passion that the issue stirs was clear in Washington when a young man jumped the barricade and tried to rush the stage before being intercepted by security. The incident caused a brief panic as people began to scatter.</p>
<p>
	Organizers hoped the second March for Our Lives rally would draw as many as 50,000 people to the Washington Monument, though the crowd seemed closer to 30,000. The 2018 event attracted more than 200,000 people, but the focus this time was on smaller marches at an estimated 300 locations.</p>
<p>
	The youth-led movement created after the Parkland shooting successfully pressured the Republican-dominated Florida state government to enact sweeping gun control changes. The group did not match that at the national level, but has persisted in advocating for gun restrictions since then, as well as participating in voter registration drives.</p>
<p>
	Survivors of mass shootings and other incidents of gun violence have lobbied legislators and testified on Capitol Hill this week. Among them was Miah Cerrillo, an 11-year-old girl who survived the shooting at Robb Elementary. She described for lawmakers how she covered herself with a dead classmate's blood to avoid being shot.</p>
<p>
	<em>Associated Press writers Jennifer Peltz in New York, David Sharp in Portland, Maine, and Chris Megerian in Los Angeles contributed to this report.</em></p>
              </div>
            <script type="text/javascript">
                 var cbAuthor = 'Ashraf Khalil And Darlene Superville';
            </script>
                                                                            <div class="sideItems">
                <div class="related">
                                                      
                                                                                                                    <div class="other-photos">
                    <h2>Photos</h2>
                                                                                                                                                                                        <div class="element teaser">
                      <div class="photo">
                                                    <a class="galleryitem" href="https://www.cp24.com/polopoly_fs/1.5943046.1654973072!/httpImage/image.jpg_gen/derivatives/landscape_960/image.jpg" title="March for Our Lives" alt="People participate in the second March for Our Lives rally in support of gun control in front of the Washington Monument, Saturday, June 11, 2022, in Washington. The rally is a successor to the 2018 march organized by student protestors after the mass shooting at a high school in Parkland, Fla. (AP Photo/Gemunu Amarasinghe)">

                            <div class="viewLarger"></div>
                                                        <img src='https://www.cp24.com/polopoly_fs/1.5943046.1654973072!/httpImage/image.jpg_gen/derivatives/landscape_225/image.jpg' alt='March for Our Lives' width='225' title='March for Our Lives' height='127' />                          </a>
                      </div>
                    </div>
                                          <p class="imgText">People participate in the second March for Our Lives rally in support of gun control in front of the Washington Monument, Saturday, June 11, 2022, in Washington. The rally is a successor to the 2018 march organized by student protestors after the mass shooting at a high school in Parkland, Fla. (AP Photo/Gemunu Amarasinghe)</p>
                                                          </div>
                                                                

                </div>
                              </div>
                        
              <script type="text/javascript">
                var paragraphs = jQuery(".articleBody").children("p").length;
                var sideItems = jQuery(".sideItems");
                                if(paragraphs > 3) {
                  sideItems.fadeOut("fast", function() {
                    var thirdItem = jQuery(".articleBody").children().eq(2);
                    jQuery(".sideItems").insertAfter(thirdItem);
                    sideItems.fadeIn("fast");
                  });
                }
              </script>
                                        <div class="StoryShareBottom">
                      
  <h2>Share:</h2>
  <div id="fb-root"></div>
<script type="text/javascript">

jQuery(document).ready(
  function(){
    window.fbAsyncInit = function() {
      FB.init({
        appId      : '117341078420651', // App ID
        channelUrl : 'https://static.ctvnews.ca/bellmedia/common/channel.html', // Channel File
        status     : true, // check login status
        cookie     : true, // enable cookies to allow the server to access the session
        xfbml      : true  // parse XFBML
      });
            FB.Event.subscribe("edge.create", function (response) {
        Tracking.trackSocial('facebook_like_btn_click');
      });
      
      // BEGIN: Facebook clicks on unlike button
      FB.Event.subscribe("edge.remove", function (response) {
        Tracking.trackSocial('facebook_unlike_btn_click');
      });
          };
   
            var plusoneOmnitureTrack = function () {
      $(function () {
        Tracking.trackSocial('google_plus_one_btn');
      })
    }
        var facebookCallback = null;
        requiresDependency('https://connect.facebook.net/en_US/all.js#xfbml=1&appId=117341078420651', facebookCallback, 'facebook-jssdk');
  });
</script>
<div class="StoryShare">
    <a id="twitter_share" href="https://twitter.com/share" class="twitter-share-button b" data-via="cp24" data-text="'Enough is enough': Thousands demand new gun safety laws" data-url="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" data-count="none">&nbsp;</a>
    <a href="https://reddit.com/submit?url=https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045&title='Enough is enough': Thousands demand new gun safety laws" target="_blank" class="reddit-button">Reddit</a>
    <div id="fbctv"><div class="fb-share-button" data-href="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" data-layout="button_count" data-size="small"><a target="_blank" href="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045&amp;src=sdkpreparse" class="fb-xfbml-parse-ignore">Share</a></div></div>
</div>                

                                                  <div class="form-submit">
                    
<div class="trust-project-wrapper">
      <style type="text/css">
      #lightbox .close {
          max-width:620px;
      }

      #lightboxcontent {
          max-width:620px;
      }

  </style>
              <a href="https://www.cp24.com/news-tips-1.1159055?url=https%253A%252F%252Fwww.cp24.com%252Fworld%252Fenough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" data-ajax-url="https://www.cp24.com/news-tips-1.1159055?ot=AjaxLayout&url=https%253A%252F%252Fwww.cp24.com%252Fworld%252Fenough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" class="lightbox_trigger">News Tips</a>
          <a href="https://www.cp24.com/report-errors-7.369891?url=https%253A%252F%252Fwww.cp24.com%252Fworld%252Fenough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" data-ajax-url="https://www.cp24.com/report-errors-7.369891?ot=AjaxLayout&url=https%253A%252F%252Fwww.cp24.com%252Fworld%252Fenough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045" class="lightbox_trigger">Report Errors</a>
      
  
  </div>
                  </div>
                                <div class="clearfix"></div>
              </div>


                                                                    <div class="currMain">
                    



  
  
    


    	
  <div class="element list videoPromoList double-top   ">
              <h3>Top Videos </h3>
                  <ul class="linklist ">
                    

      
            
              <li class="dc grid">
                                                    






    
  <div style="display: inline-table; width:187px; " class="element teaser  threecolumngridteaser grid_1 ">

          


    
   	                                      
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage unmutePlayer">
              
        	        	                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462860"   ><div class='videoIcon'>false</div><img src='https://www.cp24.com/polopoly_fs/1.5943204.1654985056!/httpImage/image.jpg_gen/derivatives/landscape_800/image.jpg' alt='Widow Loretta Rogers, front right, looks up at the funeral of her husband Ted Rogers at St. James Cathedral in Toronto on Tuesday, December, 9, 2008. Telecommunications pioneer Rogers was remembered Tuesday as not only a visionary businessman but also a devoted family man. THE CANADIAN PRESS/Nathan Denette ' width='193' title='Loretta Rogers' height='109' /></a>

                                            </div>
    <div class="bn-headline unmutePlayer">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                                                                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462860"   >Rogers matriarch Loretta Rogers dies at 83</a>

        </h2>
    </div>
    </div>

            		<div class="airClip">Air Date: June 11, 2022</div>
	      
</div>
                                                  
            
                                                        






    
  <div style="display: inline-table; width:187px; " class="element teaser  threecolumngridteaser grid_2 ">

          


    
   	                                      
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage unmutePlayer">
              
        	        	                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462834"   ><div class='videoIcon'>false</div><img src='https://www.cp24.com/polopoly_fs/1.5943132.1654980593!/httpImage/image.jpg_gen/derivatives/landscape_800/image.jpg' alt='Police remove police tape after responding to an incident on Parliament Hill in Ottawa on Saturday, June 11, 2022. THE CANADIAN PRESS/ Patrick Doyle' width='193' title='Parliament Hill' height='109' /></a>

                                            </div>
    <div class="bn-headline unmutePlayer">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                                                                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462834"   >Parliament Hill reopens after police investigation</a>

        </h2>
    </div>
    </div>

            		<div class="airClip">Air Date: June 11, 2022</div>
	      
</div>
                                                  
            
                                                        






    
  <div style="display: inline-table; width:187px; " class="element teaser  threecolumngridteaser grid_3 ">

          


    
   	                                      
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage unmutePlayer">
              
        	        	                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462840"   ><div class='videoIcon'>false</div><img src='https://www.cp24.com/polopoly_fs/1.5943201.1654984890!/httpImage/image.jpeg_gen/derivatives/landscape_800/image.jpeg' width='193' alt='Aikins' title='Aikins' height='109' /></a>

                                            </div>
    <div class="bn-headline unmutePlayer">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                                                                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462840"   >Respect choice about mask-wearing: Aikins</a>

        </h2>
    </div>
    </div>

            		<div class="airClip">Air Date: June 11, 2022</div>
	      
</div>
                                              <div class="clearfix"></div></li>
                    
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
  
  
    <br/>
<br/>
  
  
  
    

<div>
  
  



  
  
          



<div class="columnsplitter container threeColumns listHorizontal border_top">
        
      <div class="column col1  ">
      



  
  
    



  <div class="element list videoPromoList   ">
              <h3>Local News </h3>
                  <ul class="linklist ">
                                            
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:204px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage ">
                                        
    
        <a   href="https://www.cp24.com/news/ottawa-police-end-investigation-that-prompted-evacuation-of-parliament-hill-1.5943070"   ><img src='https://www.cp24.com/polopoly_fs/1.5943124.1654979931!/httpImage/image.jpg_gen/derivatives/landscape_190/image.jpg' alt='Police respond to an incident on Parliament Hill in Ottawa on Saturday, June 11, 2022. THE CANADIAN PRESS/ Patrick Doyle' width='190' title='Parliament Hill' height='107' /></a>

                                            </div>
    <div class="bn-headline ">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                            
    
        <a   href="https://www.cp24.com/news/ottawa-police-end-investigation-that-prompted-evacuation-of-parliament-hill-1.5943070"   >Ottawa Police end investigation that prompted evacuation of Parliament Hill</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
  
  
    



  <div class="element list none   ">
                  <ul class="linklist vertical">
                          
            
                                <li class='newUpdate listItem_7_697701_1497462016_190070035' updated='1654978910180' created='1654978860190'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/news/loretta-rogers-director-and-matriarch-of-rogers-communications-inc-dies-at-83-1.5943055"  title="Loretta Rogers, director and matriarch of Rogers Communications Inc., dies at 83" >Loretta Rogers, director and matriarch of Rogers Communications Inc., dies at 83</a>

                                                        </li>
        
            
                                <li class='newUpdate listItem_7_697701_1497462016_190070035' updated='1654965950729' created='1654965600140'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/news/two-people-dead-in-two-vehicle-crash-in-york-region-1.5942964"  title="Two people dead in two-vehicle crash in York Region" >Two people dead in two-vehicle crash in York Region</a>

                                                        </li>
  <script type="text/javascript">
  jQuery(document).ready(function(){
    var listItems = jQuery(".listItem_" + "7_697701_1497462016_190070035");
    var currentTime = new Date().getTime();
    var updateTimer = 60*60*1000;
    var tenMinutesAgo = currentTime - updateTimer;
    var updatedString = "UPDATED";
    var newString = "NEW";
    listItems.each(function() {
      var item = $(this);
      var modifiedTime = item.attr("updated");
      var publishedTime = item.attr("created");
      var linkElement = item.find("a").first();
      if (modifiedTime != undefined && publishedTime != undefined) {
        modifiedTime = new Number(modifiedTime);
        publishedTime = new Number(publishedTime);
        if (modifiedTime > publishedTime && currentTime > modifiedTime && modifiedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-update'>" + updatedString + " </span></span></span>");
        } else if (currentTime > publishedTime && publishedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-new'>" + newString + " </span></span></span>");
        }
      }
    });
  });
</script>            
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
</div>
<div class="column col2  ">
      



  
  
    



  <div class="element list none   ">
              <h3>World News </h3>
                  <ul class="linklist ">
                                            
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:204px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage ">
                                        
    
        <a   href="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045"   ><img src='https://www.cp24.com/polopoly_fs/1.5943188.1654983876!/httpImage/image.jpg_gen/derivatives/landscape_190/image.jpg' alt='People hold signs in the second March for Our Lives rally in support of gun control in front of the Washington Monument, Saturday, June 11, 2022, in Washington. The rally is a successor to the 2018 march organized by student protestors after the mass shooting at a high school in Parkland, Fla. (AP Photo/Jose Luis Magana)' width='190' title='March for Our Lives' height='107' /></a>

                                            </div>
    <div class="bn-headline ">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                            
    
        <a   href="https://www.cp24.com/world/enough-is-enough-thousands-demand-new-gun-safety-laws-1.5943045"   >'Enough is enough': Thousands demand new gun safety laws</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
  
  
    



  <div class="element list none   ">
                  <ul class="linklist vertical">
                          
            
                                <li class='newUpdate listItem_7_697712_1497464076_190070041' updated='1654978543110' created='1654978200503'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/world/russia-said-to-be-using-more-deadly-weapons-in-ukraine-1.5943104"  title="Russia said to be using more deadly weapons in Ukraine" >Russia said to be using more deadly weapons in Ukraine</a>

                                                        </li>
        
            
                                <li class='newUpdate listItem_7_697712_1497464076_190070041' updated='1654959759845' created='1654959759856'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/world/ukraine-uk-man-s-family-devastated-by-death-sentence-1.5942911"  title="Ukraine: UK man's family 'devastated' by death sentence" >Ukraine: UK man's family 'devastated' by death sentence</a>

                                                        </li>
  <script type="text/javascript">
  jQuery(document).ready(function(){
    var listItems = jQuery(".listItem_" + "7_697712_1497464076_190070041");
    var currentTime = new Date().getTime();
    var updateTimer = 60*60*1000;
    var tenMinutesAgo = currentTime - updateTimer;
    var updatedString = "UPDATED";
    var newString = "NEW";
    listItems.each(function() {
      var item = $(this);
      var modifiedTime = item.attr("updated");
      var publishedTime = item.attr("created");
      var linkElement = item.find("a").first();
      if (modifiedTime != undefined && publishedTime != undefined) {
        modifiedTime = new Number(modifiedTime);
        publishedTime = new Number(publishedTime);
        if (modifiedTime > publishedTime && currentTime > modifiedTime && modifiedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-update'>" + updatedString + " </span></span></span>");
        } else if (currentTime > publishedTime && publishedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-new'>" + newString + " </span></span></span>");
        }
      }
    });
  });
</script>            
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
</div>
<div class="column col3   ">
      



  
  
    



  <div class="element list none   ">
              <h3>Real Estate News </h3>
                  <ul class="linklist ">
                                            
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:204px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage ">
                                        
    
        <a   href="https://www.cp24.com/news/homeowners-who-stretched-themselves-financially-to-get-into-market-now-pose-key-risk-to-financial-system-bank-of-canada-1.5939461"   ><img src='https://www.cp24.com/polopoly_fs/1.5939462.1654767650!/httpImage/image.jpg_gen/derivatives/landscape_190/image.jpg' alt='The Bank of Canada building is seen on Wellington Street in Ottawa, on Tuesday, May 31, 2022. The Bank of Canada will outline what it sees as the key vulnerabilities and risks to Canada&#39;s financial system later this morning. THE CANADIAN PRESS/Justin Tang' width='190' title='Bank of Canada ' height='107' /></a>

                                            </div>
    <div class="bn-headline ">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                            
    
        <a   href="https://www.cp24.com/news/homeowners-who-stretched-themselves-financially-to-get-into-market-now-pose-key-risk-to-financial-system-bank-of-canada-1.5939461"   >Homeowners who stretched themselves financially to get into market now pose key risk to financial system: Bank of Canada</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
  
  
    



  <div class="element list none   ">
                  <ul class="linklist vertical">
                          
            
                                <li class='newUpdate listItem_7_697713_1497464275_190070047' updated='1652865471322' created='1652865420332'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/news/worry-buyer-s-remorse-high-as-real-estate-market-slowdown-materializes-1.5908280"  title="Worry, buyer's remorse high as real estate market slowdown materializes" >Worry, buyer's remorse high as real estate market slowdown materializes</a>

                                                        </li>
        
            
                                <li class='newUpdate listItem_7_697713_1497464275_190070047' updated='1652728385993' created='1652728386004'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/news/crea-reports-home-sales-down-in-april-as-mortgage-rates-rise-1.5905596"  title="CREA reports home sales down in April as mortgage rates rise" >CREA reports home sales down in April as mortgage rates rise</a>

                                                        </li>
  <script type="text/javascript">
  jQuery(document).ready(function(){
    var listItems = jQuery(".listItem_" + "7_697713_1497464275_190070047");
    var currentTime = new Date().getTime();
    var updateTimer = 60*60*1000;
    var tenMinutesAgo = currentTime - updateTimer;
    var updatedString = "UPDATED";
    var newString = "NEW";
    listItems.each(function() {
      var item = $(this);
      var modifiedTime = item.attr("updated");
      var publishedTime = item.attr("created");
      var linkElement = item.find("a").first();
      if (modifiedTime != undefined && publishedTime != undefined) {
        modifiedTime = new Number(modifiedTime);
        publishedTime = new Number(publishedTime);
        if (modifiedTime > publishedTime && currentTime > modifiedTime && modifiedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-update'>" + updatedString + " </span></span></span>");
        } else if (currentTime > publishedTime && publishedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-new'>" + newString + " </span></span></span>");
        }
      }
    });
  });
</script>            
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
</div>    <div class="clearfix"></div>
</div>
<div class="clearfix"></div>

  
  
  
          



<div class="columnsplitter container threeColumns listHorizontal">
        
      <div class="column col1  ">
      



  
  
    



  <div class="element list none   ">
              <h3>Sports News </h3>
                  <ul class="linklist ">
                                            
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:204px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage ">
                                        
    
        <a   href="https://www.cp24.com/sports/finau-mcilroy-co-leaders-at-canadian-open-after-three-rounds-taylor-is-low-canadian-1.5943190"   ><img src='https://www.cp24.com/polopoly_fs/1.5943191.1654984214!/httpImage/image.jpg_gen/derivatives/landscape_190/image.jpg' alt='Tony Finau of the United States hits his tee shot on the 17th hole during round three of the Canadian Open at St. George&#39;s Golf and Country Club in Toronto on Saturday, June 11, 2022. THE CANADIAN PRESS/Nathan Denette' width='190' title='Finau' height='107' /></a>

                                            </div>
    <div class="bn-headline ">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                            
    
        <a   href="https://www.cp24.com/sports/finau-mcilroy-co-leaders-at-canadian-open-after-three-rounds-taylor-is-low-canadian-1.5943190"   >Finau, McIlroy co-leaders at Canadian Open after three rounds, Taylor is low Canadian</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
  
  
    



  <div class="element list none   ">
                  <ul class="linklist vertical">
                          
            
                                <li class='newUpdate listItem_7_697714_1497464496_190070054' updated='1654981250301' created='1654981250311'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/sports/u-s-judge-dismisses-cristiano-ronaldo-rape-lawsuit-in-vegas-1.5943139"  title="U.S. judge dismisses Cristiano Ronaldo rape lawsuit in Vegas" >U.S. judge dismisses Cristiano Ronaldo rape lawsuit in Vegas</a>

                                                        </li>
        
            
                                <li class='newUpdate listItem_7_697714_1497464496_190070054' updated='1654974074281' created='1654968420398'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/sports/tatum-s-time-celtics-star-vows-to-bounce-back-in-finals-1.5943002"  title="Tatum's Time: Celtics' star vows to bounce back in Finals" >Tatum's Time: Celtics' star vows to bounce back in Finals</a>

                                                        </li>
  <script type="text/javascript">
  jQuery(document).ready(function(){
    var listItems = jQuery(".listItem_" + "7_697714_1497464496_190070054");
    var currentTime = new Date().getTime();
    var updateTimer = 60*60*1000;
    var tenMinutesAgo = currentTime - updateTimer;
    var updatedString = "UPDATED";
    var newString = "NEW";
    listItems.each(function() {
      var item = $(this);
      var modifiedTime = item.attr("updated");
      var publishedTime = item.attr("created");
      var linkElement = item.find("a").first();
      if (modifiedTime != undefined && publishedTime != undefined) {
        modifiedTime = new Number(modifiedTime);
        publishedTime = new Number(publishedTime);
        if (modifiedTime > publishedTime && currentTime > modifiedTime && modifiedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-update'>" + updatedString + " </span></span></span>");
        } else if (currentTime > publishedTime && publishedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-new'>" + newString + " </span></span></span>");
        }
      }
    });
  });
</script>            
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
</div>
<div class="column col2  ">
      



  
  
    



  <div class="element list none   ">
              <h3>Entertainment News </h3>
                  <ul class="linklist ">
                                            
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:204px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage ">
                                        
    
        <a   href="https://www.cp24.com/entertainment-news/justin-bieber-is-showing-early-signs-of-recovery-surgeon-says-1.5943170"   ><img src='https://www.cp24.com/polopoly_fs/1.5942141.1654893768!/httpImage/image.jpg_gen/derivatives/landscape_190/image.jpg' width='190' alt='Justin Bieber' title='Justin Bieber' height='107' /></a>

                                            </div>
    <div class="bn-headline ">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                            
    
        <a   href="https://www.cp24.com/entertainment-news/justin-bieber-is-showing-early-signs-of-recovery-surgeon-says-1.5943170"   >Justin Bieber is showing early signs of recovery, surgeon says</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
  
  
    



  <div class="element list none   ">
                  <ul class="linklist vertical">
                          
            
                                <li class='newUpdate listItem_7_697715_1497464549_190070060' updated='1654974147939' created='1654960980352'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/entertainment-news/they-might-be-giants-singer-guitarist-injured-in-nyc-crash-1.5942918"  title="They Might Be Giants singer-guitarist injured in NYC crash" >They Might Be Giants singer-guitarist injured in NYC crash</a>

                                                        </li>
        
            
                                <li class='newUpdate listItem_7_697715_1497464549_190070060' updated='1654892634079' created='1654890000575'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/entertainment-news/justin-bieber-says-serious-health-condition-causing-face-paralysis-reason-for-cancelling-concerts-1.5942030"  title="Justin Bieber says 'serious' health condition causing face paralysis reason for cancelling concerts" >Justin Bieber says 'serious' health condition causing face paralysis reason for cancelling concerts</a>

                                                        </li>
  <script type="text/javascript">
  jQuery(document).ready(function(){
    var listItems = jQuery(".listItem_" + "7_697715_1497464549_190070060");
    var currentTime = new Date().getTime();
    var updateTimer = 60*60*1000;
    var tenMinutesAgo = currentTime - updateTimer;
    var updatedString = "UPDATED";
    var newString = "NEW";
    listItems.each(function() {
      var item = $(this);
      var modifiedTime = item.attr("updated");
      var publishedTime = item.attr("created");
      var linkElement = item.find("a").first();
      if (modifiedTime != undefined && publishedTime != undefined) {
        modifiedTime = new Number(modifiedTime);
        publishedTime = new Number(publishedTime);
        if (modifiedTime > publishedTime && currentTime > modifiedTime && modifiedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-update'>" + updatedString + " </span></span></span>");
        } else if (currentTime > publishedTime && publishedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-new'>" + newString + " </span></span></span>");
        }
      }
    });
  });
</script>            
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
</div>
<div class="column col3   ">
      



  
  
    



  <div class="element list none   ">
              <h3>Lifestyle News </h3>
                  <ul class="linklist ">
                                            
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:204px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage ">
                                        
    
        <a   href="https://www.cp24.com/news/what-is-ramsay-hunt-syndrome-justin-bieber-s-diagnosis-explained-1.5942235"   ><img src='https://www.cp24.com/polopoly_fs/1.5942242.1654896930!/httpImage/image.jpg_gen/derivatives/landscape_190/image.jpg' alt='Justin Bieber attends The Metropolitan Museum of Art&#39;s Costume Institute benefit gala in New York on September 13, 2021. Bieber says he&#39;s been diagnosed with Ramsay Hunt Syndrome, a virus that has left the right side of his face paralyzed. THE CANADIAN PRESS/AP, Invision - Evan Agostini' width='190' title='Bieber' height='107' /></a>

                                            </div>
    <div class="bn-headline ">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                            
    
        <a   href="https://www.cp24.com/news/what-is-ramsay-hunt-syndrome-justin-bieber-s-diagnosis-explained-1.5942235"   >What is Ramsay Hunt syndrome? Justin Bieber's diagnosis explained</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
  
  
    



  <div class="element list none   ">
                  <ul class="linklist vertical">
                          
            
                                <li class='newUpdate listItem_7_697716_1497464587_190070066' updated='1654899242651' created='1654886700319'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/news/ottawa-suspends-random-covid-testing-for-vaccinated-travellers-at-airports-1.5941950"  title="Ottawa suspends random COVID testing for vaccinated travellers at airports" >Ottawa suspends random COVID testing for vaccinated travellers at airports</a>

                                                        </li>
        
            
                                <li class='newUpdate listItem_7_697716_1497464587_190070066' updated='1654892293132' created='1654885980291'>
              
                                                                  	                
    
        <a   href="https://www.cp24.com/news/new-canadian-regulations-would-put-warning-on-each-cigarette-not-just-packaging-1.5941930"  title="New Canadian regulations would put warning on each cigarette, not just packaging" >New Canadian regulations would put warning on each cigarette, not just packaging</a>

                                                        </li>
  <script type="text/javascript">
  jQuery(document).ready(function(){
    var listItems = jQuery(".listItem_" + "7_697716_1497464587_190070066");
    var currentTime = new Date().getTime();
    var updateTimer = 60*60*1000;
    var tenMinutesAgo = currentTime - updateTimer;
    var updatedString = "UPDATED";
    var newString = "NEW";
    listItems.each(function() {
      var item = $(this);
      var modifiedTime = item.attr("updated");
      var publishedTime = item.attr("created");
      var linkElement = item.find("a").first();
      if (modifiedTime != undefined && publishedTime != undefined) {
        modifiedTime = new Number(modifiedTime);
        publishedTime = new Number(publishedTime);
        if (modifiedTime > publishedTime && currentTime > modifiedTime && modifiedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-update'>" + updatedString + " </span></span></span>");
        } else if (currentTime > publishedTime && publishedTime > tenMinutesAgo) {
            $(linkElement).before("<span class='eHub-div eHub-height'><span class='eHub-white-bg'><span class='tag eHub-new'>" + newString + " </span></span></span>");
        }
      }
    });
  });
</script>            
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
</div>    <div class="clearfix"></div>
</div>
<div class="clearfix"></div>

  

  </div>
  
  
  
    <br/>
<br/>
  
  
  
    
        

<div class="element tabviewelement bothSideAlign">

  


     <div id="tabs_7_699729_1580939015_190070070" class="bothSideAlign">
    <ul>
      
      <li><a href="#tabs_7_699729_1580939015_190070070_tab1"><span Style="width:620px;">CP24 on Twitter</span></a></li>
        </ul>
        <div id="tabs_7_699729_1580939015_190070070_tab1"><a class="twitter-timeline" height="650" data-chrome="noheader nofooter transparent" href="https://twitter.com/CP24">Tweets by CP24</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></div>
      </div>
<script type="text/javascript">
    jQuery(document).ready(
      function(){
        requiresDependency('https://static.ctvnews.ca/bellmedia/common/js/jquery-ui-tabs-1.5.packed.js', function() {
          requiresDependency('https://static.ctvnews.ca/bellmedia/common/js/jquery-ui-1.8.18.custom.min.js', function() {
            jQuery("#tabs_7_699729_1580939015_190070070 > ul").tabs();
          });
        });
      });
    </script>

</div>
  
                                    </div>
                                                            



                                                                                                        

                            
            </div>
          </div>
        </div>
                              <script type="text/javascript">
           jQuery(function() {
              jQuery('a.galleryitem').lightBox();
                                          jQuery("a.galleryitem").click(function() {
                trackLightbox(false, jQuery(this).attr("title"));
              });
                         });

          </script>
                        
        
                                <script type="text/javascript">
           jQuery(function() {
                                            Tracking.setValue(32,"The Associated Press");
                                                Tracking.setValue(33,"Ashraf Khalil And Darlene Superville");
                                                         });

          </script>
                        
      </section>

                                      </div><!-- END .content-primary -->
          
    <!-- if(content.righttop || content.boxads) -->
          <div class="content-secondary">
                <div class="sidebar">
                                    



  
  
    
                                    <div class="boxAd ">
							                            <div class="advert">
        
                        
                                                                                              
               
	        	          								<div id="div-gpt-ad-300_250-2">
				<script type="text/javascript">
				    if (document.querySelector('.advert') !== null) {
				        googletag.cmd.push(function () {
				            headertag.display("div-gpt-ad-300_250-2");
				        });
				    }
				</script>
				</div>
	          	                
                    								<p class="ad-below">Advertisement</p>
							            </div>
                
                    </div>
        
    
  
  
  
  
    

<div class='rightrailDefaultPoll'>
  
  




  </div>
  
  
  
    

<div>
  
  



  
  
    <h2>MOST READ</h2>
  
  
  
    



  <div class="element list topstorybn   ">
              <ul class="linklist ">
                                            
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:300px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage ">
                                        
    
        <a   href="https://www.cp24.com/entertainment-news/justin-bieber-says-serious-health-condition-causing-face-paralysis-reason-for-cancelling-concerts-1.5942030"   ><img src='https://www.cp24.com/polopoly_fs/1.5942023.1654892442!/httpImage/image.jpg_gen/derivatives/landscape_300/image.jpg' alt='Justin Bieber has announced he has been diagnosed with Ramsay Hunt syndrome. (Instagram/Justin Bieber)' width='300' title='Justin Bieber Ramsay Hunt syndrome' height='169' /></a>

                                            </div>
    <div class="bn-headline ">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                            
    
        <a   href="https://www.cp24.com/entertainment-news/justin-bieber-says-serious-health-condition-causing-face-paralysis-reason-for-cancelling-concerts-1.5942030"   >Justin Bieber says 'serious' health condition causing face paralysis reason for cancelling concerts</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
                          
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:300px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage ">
                                        
    
        <a   href="https://www.cp24.com/news/here-s-where-masking-in-toronto-is-still-required-1.5942252"   ><img src='https://www.cp24.com/polopoly_fs/1.5622447.1634178858!/httpImage/image.jpg_gen/derivatives/landscape_300/image.jpg' alt='A couple walk past an inspirational mural in Toronto during the COVID-19 pandemic on Tuesday May 25, 2021. THE CANADIAN PRESS/Frank Gunn ' width='300' title='COVID-19' height='169' /></a>

                                            </div>
    <div class="bn-headline ">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                            
    
        <a   href="https://www.cp24.com/news/here-s-where-masking-in-toronto-is-still-required-1.5942252"   >Here’s where masking in Toronto is still required</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
                          
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:300px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage ">
                                        
    
        <a   href="https://www.cp24.com/news/what-is-ramsay-hunt-syndrome-justin-bieber-s-diagnosis-explained-1.5942235"   ><img src='https://www.cp24.com/polopoly_fs/1.5942242.1654896930!/httpImage/image.jpg_gen/derivatives/landscape_300/image.jpg' alt='Justin Bieber attends The Metropolitan Museum of Art&#39;s Costume Institute benefit gala in New York on September 13, 2021. Bieber says he&#39;s been diagnosed with Ramsay Hunt Syndrome, a virus that has left the right side of his face paralyzed. THE CANADIAN PRESS/AP, Invision - Evan Agostini' width='300' title='Bieber' height='169' /></a>

                                            </div>
    <div class="bn-headline ">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                            
    
        <a   href="https://www.cp24.com/news/what-is-ramsay-hunt-syndrome-justin-bieber-s-diagnosis-explained-1.5942235"   >What is Ramsay Hunt syndrome? Justin Bieber's diagnosis explained</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
                          
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:300px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage ">
                                        
    
        <a   href="https://www.cp24.com/news/more-police-officers-on-foot-coming-to-neighbourhoods-across-toronto-1.5942846"   ><img src='https://www.cp24.com/polopoly_fs/1.4116028.1538394579!/httpImage/image.jpg_gen/derivatives/landscape_300/image.jpg' width='300' alt='Neighbourhood police officers' title='Neighbourhood police officers' height='169' /></a>

                                            </div>
    <div class="bn-headline ">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                            
    
        <a   href="https://www.cp24.com/news/more-police-officers-on-foot-coming-to-neighbourhoods-across-toronto-1.5942846"   >More police officers on foot coming to neighbourhoods across Toronto</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
                          
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:300px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage ">
                                        
    
        <a   href="https://www.cp24.com/news/where-should-i-wear-a-mask-now-that-the-mandate-is-lifted-the-new-head-of-ontario-s-science-table-shares-his-advice-1.5942053"   ><img src='https://www.cp24.com/polopoly_fs/1.5634141.1634911356!/httpImage/image.jpg_gen/derivatives/landscape_300/image.jpg' alt='A disposable face mask is shown attached to a woman’s arm in Old Montreal, Sunday, July 18 2021, as the COVID-19 pandemic continues in Canada and around the world. THE CANADIAN PRESS/Graham Hughes 
' width='300' title='mask' height='169' /></a>

                                            </div>
    <div class="bn-headline ">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                            
    
        <a   href="https://www.cp24.com/news/where-should-i-wear-a-mask-now-that-the-mandate-is-lifted-the-new-head-of-ontario-s-science-table-shares-his-advice-1.5942053"   >Where should I wear a mask now that the mandate is lifted? The new head of Ontario's science table shares his advice</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
  
  
    <br/>
<br/>
  
  
  
    <h2>MOST WATCHED</h2>
  
  
  
    



  <div class="element list topstorybn   ">
              <ul class="linklist ">
                                            
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:300px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage unmutePlayer">
              
        	        	                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462637"   ><div class='vid'>false</div><img src='https://www.cp24.com/polopoly_fs/1.5942530.1654905308!/httpImage/image.jpg_gen/derivatives/landscape_300/image.jpg' width='300' alt='Pickering crash' title='Pickering crash' height='169' /></a>

                                            </div>
    <div class="bn-headline unmutePlayer">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                                                                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462637"   >Man critical after crash on Highway 401</a>

        </h2>
    </div>
    </div>

            		<div class="airClip">Air Date: June 10, 2022</div>
	      
</div>
                                        </li>
                          
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:300px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage unmutePlayer">
              
        	        	                                  
    
        <a   href="https://www.cp24.com/video?clipId=2461883"   ><div class='vid'>false</div><img src='https://www.cp24.com/polopoly_fs/1.5941093.1654826370!/httpImage/image.jpg_gen/derivatives/landscape_300/image.jpg' alt='The House select committee investigating the Jan. 6 attack on the U.S. Capitol holds its first public hearing to reveal the findings of a year-long investigation, on Capitol Hill in Washington, Thursday, June 9, 2022. (Mandel Ngan/Pool via AP)' width='300' title='Hearing' height='169' /></a>

                                            </div>
    <div class="bn-headline unmutePlayer">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                                                                                  
    
        <a   href="https://www.cp24.com/video?clipId=2461883"   >House panel holds hearing into Capitol attack</a>

        </h2>
    </div>
    </div>

            		<div class="airClip">Air Date: June 9, 2022</div>
	      
</div>
                                        </li>
                          
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:300px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage unmutePlayer">
              
        	        	                                  
    
        <a   href="https://www.cp24.com/video?clipId=1921747"   ><div class='vid'>false</div><img src='https://www.cp24.com/polopoly_fs/1.5777332.1644582787!/httpImage/image.jpeg_gen/derivatives/landscape_300/image.jpeg' width='300' alt='CP24 Breakfast' title='CP24 Breakfast' height='169' /></a>

                                            </div>
    <div class="bn-headline unmutePlayer">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                                                                                  
    
        <a   href="https://www.cp24.com/video?clipId=1921747"   >CP24 Breakfast Live Stream </a>

        </h2>
    </div>
    </div>

            		<div class="airClip">Air Date: March 13, 2020</div>
	      
</div>
                                        </li>
                          
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:300px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage unmutePlayer">
              
        	        	                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462636"   ><div class='vid'>false</div><img src='https://www.cp24.com/polopoly_fs/1.5942527.1654905246!/httpImage/image.jpg_gen/derivatives/landscape_300/image.jpg' width='300' alt='Vaughan collision' title='Vaughan collision' height='169' /></a>

                                            </div>
    <div class="bn-headline unmutePlayer">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                                                                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462636"   >Pedestrian struck by vehicle in Vaughan</a>

        </h2>
    </div>
    </div>

            		<div class="airClip">Air Date: June 10, 2022</div>
	      
</div>
                                        </li>
                          
    <li class="dc ">
                                                
          
      







  <div style="display: inline-table; width:300px; " class="element teaser   ">

          


    
   	    
    <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage unmutePlayer">
              
        	        	                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462515"   ><div class='vid'>false</div><img src='https://www.cp24.com/polopoly_fs/1.5942141.1654893768!/httpImage/image.jpg_gen/derivatives/landscape_300/image.jpg' width='300' alt='Justin Bieber' title='Justin Bieber' height='169' /></a>

                                            </div>
    <div class="bn-headline unmutePlayer">
                    <script type="text/javascript">
        jQuery(document).ready(function() {
            var arrayOfTags = jQuery("#responsive_main .topstorybn .teaser-image-wrapper .teaserImage .tag");

            jQuery.each(arrayOfTags, function(k, v){
                var parentElement = $(v).closest(".teaser-image-wrapper.teaser-image-top");
                parentElement.find(".teaserImage .tag").remove();
                parentElement.find(".bn-headline").prepend(v);
            });
        });
    </script>

            <h2 class="teaserTitle">
                                                                                                  
    
        <a   href="https://www.cp24.com/video?clipId=2462515"   > Justin Bieber opens up about cancellations </a>

        </h2>
    </div>
    </div>

            		<div class="airClip">Air Date: June 10, 2022</div>
	      
</div>
                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  

  </div>
  
                        



                  </div><!-- END .sidebar -->
      </div><!-- END div.content-secondary -->
            	<footer class="content-footer">
      	  	    



  
  
    

<div class='footernav'>
      <nav>
  
  



  
  
    <div>
            	                
    
        <a   href="https://www.cp24.com/"  title="CP24 Home" >Home</a>

        </div>

  
  
  
    <div>
            	                
    
        <a   href="https://jobs.bce.ca/bell/go/Media/3537600/"  title="Careers" >Careers</a>

        </div>

  
  
  
    <div>
            	                
    
        <a   href="http://www.bellmedia.ca/en/privacy.html"  title="Privacy Policy" >Privacy Policy</a>

        </div>

  
  
  
    <div>
            	                
    
        <a   href="http://www.bellmedia.ca/en/toc.html"  title="Terms and Conditions" >Terms and Conditions</a>

        </div>

  
  
  
    <div>
            	                
    
        <a   href="https://www.bce.ca/Accessibility_services?brand=CP24"  class="newWindow"  target="_blank"  title="Accessibility " >Accessibility </a>

        </div>

  
  
  
    <div>
            	                
    
        <a   href="https://www.cp24.com/more/contact-us"  title="Contact Us" >Contact Us</a>

        </div>

  
  
  
    <div>
            	                
    
        <a   href="https://www.cp24.com/more/about-us"  title="About Us" >About Us</a>

        </div>

  
  
  
    <div>
            	              
    
        <a   href="https://www.bellmedia.ca/sales/political-ads-registry/"  class="newWindow"  target="_blank"   >Political Ads Registry</a>

        </div>

  
  
  
    <div>
            	                
    
        <a   href="https://www.cp24.com/more/advertise-on-cp24"  title="Advertise on CP24" >Advertise on CP24</a>

        </div>

  

      </nav>
  </div>
  
  
  
    

<div class='footernav'>
      <nav>
  
  



  
  
    <div>
            	                
    
        <a   href="https://www.cp24.com/news"  title="Toronto News" >Toronto News</a>

        </div>

  
  
  
    <div>
            	                
    
        <a   href="http://www.cp24.com/world"  title="World News " >World News</a>

        </div>

  
  
  
    <div>
            	                
    
        <a   href="https://www.cp24.com/weather"  title="Weather, Toronto, GTA, cottage country" >Weather</a>

        </div>

  
  
  
    
  
  
  
    <div>
            	                
    
        <a   href="https://www.cp24.com/sports"  title="Sports news" >Sports News</a>

        </div>

  
  
  
    <div>
            	                
    
        <a   href="http://www.cp24.com/entertainment-news"  title="Entertainment News" >Entertainment News</a>

        </div>

  

      </nav>
  </div>
  
  
  
    <div class="footer-logos">
  <a class="footer-logo-link" href="https://www.ctv.ca"><img src="https://www.ctvnews.ca/polopoly_fs/1.4264165!/httpImage/image.png" height="36" width="88" alt="CTV.ca" /></a>
  <a class="footer-logo-link" href="https://www.ctv.ca"><img src="https://www.ctvnews.ca/polopoly_fs/1.4264174!/httpImage/image.png" height="36" width="88" alt="CTV Two" /></a>
  <a class="footer-logo-link" href="https://www.ctvnews.ca"><img src="//www.ctvnews.ca/polopoly_fs/7.726389!/httpImage/image.png" height="29" width="60" alt="CTVNews"/></a>
  <a class="footer-logo-link" href="https://www.ctvnews.ca/ctv-news-channel">
    <img src="https://www.ctvnews.ca/polopoly_fs/7.726390!/httpImage/image.png" height="35" width="56" alt="CTV News Channel" />
  </a>
  <a class="footer-logo-link" href="https://www.bnnbloomberg.ca">
    <img src="https://www.ctvnews.ca/polopoly_fs/7.711875!/httpImage/image.png" height="35" width="90" alt="BNN Bloomberg" />
  </a>
  <a class="footer-logo-link" href="https://www.cp24.com"><img src="https://static.ctvnews.ca/bellmedia/common/img/logos/footer-logo_cp24.jpg" height="30" width="53" alt="CP24" /></a>
</div>
<br/>
  
  
  
    <p class="terms">Use of this Website assumes acceptance of <a href="http://www.bellmedia.ca/bell-media-website-terms-conditions/" title="Terms &amp; Conditions">Terms &amp; Conditions</a> and <a href="https://support.bell.ca/Billing-and-Accounts/Security_and_privacy/How_does_Bell_respect_my_privacy" title="Privacy Policy">Privacy Policy</a></p><p class="copyright">&#169; 2022 <a href="http://www.bellmedia.ca/"><img class="copyright" src="https://static.ctvnews.ca/bellmedia/common/img/logos/bellmedia_logo.gif" alt="Bell Media" /></a> All rights reserved.</p><p class="credits"></p>
  
  
  
    

<div class='thirty-by-one'>
  
  



  
  
    
                                            <div class="">
        
                        
                                                                                              
               
	        	          								<div id="div-gpt-ad-30_1-3">
				<script type="text/javascript">
				    if (document.querySelector('.advert') !== null) {
				        googletag.cmd.push(function () {
				            headertag.display("div-gpt-ad-30_1-3");
				        });
				    }
				</script>
				</div>
	          	                
                
                    </div>
        
    
  
  

  </div>
  
  
  
    <a name="pagetop"></a>
<div id='div-gpt-ad-outofpage-1-oop' style='height: 0; width: 0'>
   <script type='text/javascript'>
     googletag.cmd.push(function() {
       headertag.display('div-gpt-ad-outofpage-1-oop');
     });
    </script>
</div>

  
	        <p><a class="back-top hidden" href="#top" title="skip to top of page">Back to top</a></p>

</footer><!-- END #content-footer -->      </div><!-- END div.content-wrapper -->
</div><!-- END .content -->
                      <style>
  .sidebar .element.list.li-divider .vid {z-index: auto}
  </style>                      <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/jquery.form.js" ></script>
                    <script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "3005664" });
  
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/cs/3005664/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>                        
        <script type="text/javascript">
            (function() {
                /** CHARTBEAT CONFIGURATION START **/
                var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});

                                _sf_async_config.sections = 'CP24, World';
                
                _sf_async_config.authors = cbAuthor; // CHANGE THIS TO YOUR AUTHOR NAME(s)
                /** CHARTBEAT CONFIGURATION END **/
                function loadChartbeat() {
                var e = document.createElement('script');
                var n = document.getElementsByTagName('script')[0];
                e.type = 'text/javascript';
                e.async = true;
                e.src = '//static.chartbeat.com/js/chartbeat_video.js';;
                n.parentNode.insertBefore(e, n);
                }
                loadChartbeat();
            })();
        </script>

                          <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/common.js?v2" ></script>
                      <script type="text/javascript" charset="utf-8">
try {
  if (window.external.msIsSiteMode()) {
    window.external.msSiteModeClearJumpList();
    window.external.msSiteModeCreateJumpList("News Headlines");
                  window.external.msSiteModeAddJumpListItem("Loretta Rogers, director and matriarch of Rogers Communications Inc., dies at 83", "https://www.cp24.com/news/loretta-rogers-director-and-matriarch-of-rogers-communications-inc-dies-at-83-1.5943055", "http://static.ctvnews.ca/bellmedia/cp24/img/favicon.ico", "self");
              window.external.msSiteModeAddJumpListItem("Two people dead in two-vehicle crash in York Region", "https://www.cp24.com/news/two-people-dead-in-two-vehicle-crash-in-york-region-1.5942964", "http://static.ctvnews.ca/bellmedia/cp24/img/favicon.ico", "self");
              window.external.msSiteModeAddJumpListItem("Toronto bathhouse workers among first to be offered monkeypox vaccine  ", "https://www.cp24.com/news/toronto-bathhouse-workers-among-first-to-be-offered-monkeypox-vaccine-1.5942928", "http://static.ctvnews.ca/bellmedia/cp24/img/favicon.ico", "self");
              window.external.msSiteModeAddJumpListItem("Motorcyclist in life-threatening condition following head-on crash east of Peterborough", "https://www.cp24.com/news/motorcyclist-in-life-threatening-condition-following-head-on-crash-east-of-peterborough-1.5943019", "http://static.ctvnews.ca/bellmedia/cp24/img/favicon.ico", "self");
              window.external.msSiteModeAddJumpListItem("Ottawa Police end investigation that prompted evacuation of Parliament Hill", "https://www.cp24.com/news/ottawa-police-end-investigation-that-prompted-evacuation-of-parliament-hill-1.5943070", "http://static.ctvnews.ca/bellmedia/cp24/img/favicon.ico", "self");
            }
} 
catch (ex) {
    // Fail silently.
}
</script>  <div id="pinning-discoverability"> </div> 
<script type="text/javascript" charset="utf-8">
  $(document).ready(function () {
    $('#pinning-discoverability').pinable(
      {
        closeTitle: 'Close', // default close title
        containerElement: 'body', // element that pinning html will be prepended to
        cookieName: 'cp24_new-pin', // name of cookie; default is iePinning_yourdomain.com
        cookieLength: 30, // in days; default is 30 days
        debug: false, // debug mode; forces the banner to always show, even across browsers
        discStyle: 'toast', // discoverability style; options are toast, topHat and pushUp
        dragAlt: 'Drag me!', // default drag icon alt text
        elementId: 'pinning-discoverability', // Id of banner container that will be injected
        logoPath: 'https://www.cp24.com/polopoly_fs/7.637153!/defaultIcon/icon-32x32.jpg', // path to the 32px x 32px logo file
        message: 'Pin CP24.com to your taskbar to stay up to date with the latest news',
        slideDuration: 'fast', // change the slide speed
        useCookie: true // toggles cookies on/off; default is on
    });
  });
</script>
                  <script type="text/javascript">
        var _gaq = _gaq || []; 
                        _gaq.push(['_setAccount', 'UA-19847838-1']);
    _gaq.push(['_setDomainName', 'cp24.com']);
          _gaq.push(['_trackPageview']);
    
    jQuery(document).ready(function() {
        var insertGATriggers = function() {
                    jQuery("a[data-gaTrackingEvent]").bind('click', function() {
            var gaTrackingEvent = jQuery(this).attr('data-gaTrackingEvent');
            var gaTrackingCategory = jQuery(this).attr('data-gaTrackingCategory');
            var gaTrackingAction = jQuery(this).attr('data-gaTrackingAction');
            var gaTrackingLabel = jQuery(this).attr('data-gaTrackingLabel');
            if (typeof gaTrackingLabel == 'undefined') {
                gaTrackingLabel = "";
            }
            _gaq.push([gaTrackingEvent, gaTrackingCategory, gaTrackingAction, gaTrackingLabel]);
          });
        };
        var ga_src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
        requiresDependency(ga_src,insertGATriggers);
    });
</script>            <img src='/logger/p.gif?a=1.5943045&amp;d=/2.628/2.629/2.614/2.934' alt='' />    <script type="text/javascript">
    jQuery('body').bind('logger', function(event) {
      if (event.a) {
        if (!event.d) {
          event.d = '/2.628/2.629/2.614/2.934';
        }
        jQuery.ajax({url:'/logger/p.gif', data:{a:event.a, d:event.d}});
      }
    });
  </script>
              

          
  <script type="text/javascript"> _AUTO_TRACK = false; </script>
            <script type="text/javascript" src="//beta.ctvnews.ca/content/dam/static-resources/includeAuth3.js"></script>
  <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/omnitureTVE.js"></script>
  
  <script type="text/javascript">
                        
   	  	  	    // var d = new Date();
    // console.log('Before: ', d.toLocaleTimeString());
    // setTimeout( () => {
    setupOmnitureTracking(
      "ctvgmtvecp24desktop",
      "CP24",
      "News",
      "cp24",
      "story",
      "www",
       "CP24",       "true",
      "false",
      false,
      false,
      "ctvgmtvecp24globalsuite");
    // }, 1500);
    // var d = new Date();
    // console.log('After: ', d.toLocaleTimeString());
       _satellite.pageBottom();
  
  </script>

         <script type="text/javascript">
      jQuery(document).ready(
      function(){
                                                          trackContent(false, "'Enough is enough': Thousands demand new gun safety laws");
                                    });
      </script>
         <script src="https://tru.am/scripts/custom/ctvnews.js"></script>
    <script>
    jQuery(document).ready(
        function(){
          requiresDependency('https://static.ctvnews.ca/bellmedia/common/js/trustProject.js', function() {initTrustLabel()})
        })
  </script>
</body>
</html>
